Crony Capitalists in Our Backyards  EPB

Crony Capitalists in Our Backyards EPB

Who They Are, What They Do and How to Fight Back
  • On Sale: Oct 04, 2011
  • ISBN: 9780062123824
  • Format: EPUB

New from Voices of the Tea Party. In Crony Capitalism in Our Back Yards, Amy Handlin, a Harvard educated Republican member of New Jersey’s General Assembly, demonstrates that crony capitalism is as much of a problem at the state and local level as it is at the federal level. Drawing on her personal experiences, Ms. Handlin paints a colorful picture of some of the political insiders who’ve used their positions of power to advance their own financial interests at the expense of the public welfare . Ms. Handlin concludes with a set of practical recommendations that average citizens can undertake to fight crony capitalism in their own back yards.

Amy Handlin

Amy Handlin is Deputy Minority Leader of the New Jersey General Assembly and Associate Professor of Marketing at Monmouth University. She is a past member of the New Jersey Commission on Higher Education and a former Senior Fellow at Monmouth University's Center for the Study of Public Issues. Dr. Handlin is a graduate of Harvard University, holds an MBA from Columbia University and a Ph.D. in Marketing from New York University's Stern School of Business. Prior to being elected to the legislature, she served on the governing body of Monmouth County and as Deputy Mayor of Middletown Township, where she lives with husband David, son Daniel and daughter Rebecca.


Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366