How the GOP Establishment Is Co-Opting the Freshman Tea Party Class

How the GOP Establishment Is Co-Opting the Freshman Tea Party Class

  • On Sale: May 31, 2011
  • ISBN: 9780062112606
  • Format: EPUB
In this first-hand account of the perils of Washington, Constance Dogood, an average American who became an early leader of the Tea Party movement, describes the methods used by the Republican Establishment to co-opt the Freshman members of Congress. Called "the Tea Party Class" because they were propelled into office by a wave of Tea Party support, these 63 new Republican members of Congress face a daunting challenge in the 112th Congress. On the one hand, they need to honor the promises they made to the tea partiers in their districts who helped elect them. On the other hand, they need to learn the ropes of Washington without unnecessarily alienating the Republican Establishment so long entrenched in and around the corridors of power. Constance concludes that the House of Representatives would be well advised to ditch the century old hierarchical party leadership structure and look to the Tea Party movement itself for a superior model of organizing to return the country to its constitutional roots.

Constance Dogood

Constance Dogood is a Tea Party leader who now works on staff for a newly elected Republican member of Congress.


Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366

Notice: curl_setopt() [function.curl-setopt]: CURLOPT_SSL_VERIFYHOST with value 1 is deprecated and will be removed as of libcurl 7.28.1. It is recommended to use value 2 instead in /nfs/c10/h02/mnt/150116/domains/broadsidebooks.net/html/wp-includes/class-http.php on line 1366